A rather unfortunate bug… But aren’t they all?


The other day I was testing various charting components, including XCeed, Nevron and DevExpress. All components really looked nice in regards to API, Layout and Look N Feel.
I have run several tests on all three components, and have a hard time deciding which one to choose for our project (if any of the three).

Today I hit a strange behaviour with the DevExpress trial installation. While I was adding a class in VS2010, by right clicking and choosing ‘add class’ I got a lot more than just a class.
In fact the DevExpress trial package deemed it necessary to add a reference to every DevExpress library in the current project, see image:

DevExpress Issue 1

The fact that the project is a businesslayer makes matters worse…
I think DevExpress has some fixing to do 🙂

UPDATE:
This seems to have been caused by what I call a “Monday Computer”.
I havent been able to reproduce the bug, except for the day it occurred.
DevExpress has been very willing to help and very alert, through especially Mehul Harry and Seth Juarez

Reklamer

One response to this post.

  1. Posted by Bryan on 2011/03/05 at 05:27

    Hello my name is Bryan and I am the charting evangelist for DevExpress. If you have some time to chat I’ve handed this off to our dev team and they are looking into it further. Any other information you could add would be very helpful. Additionally if you have any other questions I’d be happy to help.

    Thanks,

    Bryan

    Svar

Skriv et svar

Udfyld dine oplysninger nedenfor eller klik på et ikon for at logge ind:

WordPress.com Logo

Du kommenterer med din WordPress.com konto. Log Out / Skift )

Twitter picture

Du kommenterer med din Twitter konto. Log Out / Skift )

Facebook photo

Du kommenterer med din Facebook konto. Log Out / Skift )

Google+ photo

Du kommenterer med din Google+ konto. Log Out / Skift )

Connecting to %s

%d bloggers like this: